Home > MOM/SCOM, Softgrid > SCOM 2007: Error in ADMP

SCOM 2007: Error in ADMP


A customer has imported an ADMP, and soon after running it, he started to get the following error:

AD Replication Monitoring : encountered a runtime error. Failed to obtain the InfrastructureMaster using a well known GUID.

The error returned was: ‘Failed to get the ‘fSMORoleOwner’ attribute from the object ‘LDAP://SERVERNAME/’.

The error returned was: ‘There is no such object on the server.’ (0x80072030)’ (0x80072030)

 

To solve this issue follow the below steps:

1. Run Adsiedit.msc
2. Connect to the DC=DomainDnsZones,DC=xxx,DC=xxx ,DC=xxx partition.
3. Open the properties for the Infrastructure object.
4. Look at the fSMORoleOwner attribute and it is set to CN=NTDSSettingsADEL:ed7c8fe9-c5cd-4101-bf57-7468c606a6be,CN=IOWADC4ADEL:ecaeecd1-dea1-44ac-9a3c-fb827fd6d085,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configuration,DC=xxx,
DC=xxx
5. If this particular record is set to delete, then remove the above entry and then add the correct attribute for the current FSMO role holder.

Thanks to MCS SA for sharing this info that made my life easier.

Categories: MOM/SCOM, Softgrid
  1. No comments yet.
  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: